Cara Backup Konfigurasi Mikrotik Ke Email Gmail

Cara Backup Konfigurasi Mikrotik Ke Email Gmail

Diposting pada

Bagaiamana cara backup konfigurasi Mikrotik ke email Gmail? Backup konfigurasi mikrotik secara berkala sangat membantu dan memudahkan saat harus konfigurasi ulang Mikrotik.

Saat router di reset atau crash otomatis butuh konfigurasi ulang. Saat Anda tidak melakukan backup konfigurasi maka akan merepotkan.

Untuk itu backup harian konfigurasi mikrotik akan sangat memabantu jika suatu saat akan melakukan konfigurasi ulang.

Untuk backup mikrotik configuration Anda bisa mengirimkan file hasil backupnya secara otomatis ke email. Kali ini goozir.com akan mencoba memberikan tutorial bagaimana backup konfiguarsi mikrotik ke akun Gmail.

Backup Konfigurasi Mikrotik Ke Gmail

Untuk backup konfigurasi mikrotik ke gmail, Anda bisa memanfaatkn SMTP bawaan Gmail untuk mengirim email ke Anda.

Tentunya Anda harus memiliki akun email Gmail jika belum punya Anda bisa membuat akun email Gmail terlebih dahulu.

Untuk memulai konfigurasi backup otomatis konfiigurasi mikrotik ke Gmail Anda harus menambahkan script baru dengan nama backup

Script Backup Mikrotik

Buka System >> Script >> kasih nama backup

cara Backup konfigurasi mikrotik

Jangan lupa centang semua policy seperti gambar di bawah ini.

Isikan script dengan kode dibawah ini

#### Modify these values to match your requirements ####
 
#Your email address to receive the backups
:local toemail "alamat[at]gmailanda.com"
 
#The From address (you can use your own address if you want)
:local fromemail "alamat[at]gmailanda.com"
 
#A mail server your machines can send through
:local emailserver "74.125.200.108"
 
:local password "PasswordGmailAnda"
 
############## Don’t edit below this line ##############
 
 
:local sysname [/system identity get name]
:local textfilename
:local backupfilename
:local time [/system clock get time]
:local date [/system clock get date]
:local newdate "";
:for i from=0 to=([:len $date]-1) do={ :local tmp [:pick $date $i];
:if ($tmp !="/") do={ :set newdate "$newdate$tmp" }
:if ($tmp ="/") do={}
}
#check for spaces in system identity to replace with underscores
:if ([:find $sysname " "] !=0) do={
:local name $sysname;
:local newname "";
:for i from=0 to=([:len $name]-1) do={ :local tmp [:pick $name $i];
:if ($tmp !=" ") do={ :set newname "$newname$tmp" }
:if ($tmp =" ") do={ :set newname "$newname_" }
}
:set sysname $newname;
}
:set textfilename ($"newdate" . "-" . $"sysname" . ".rsc")
:set backupfilename ($"newdate" . "-" . $"sysname" . ".backup")
:execute [/export file=$"textfilename"]
:execute [/system backup save name=$"backupfilename"]
#Allow time for export to complete
:delay 2s
 
 
#email copies
:log info "Emailing backups"
/tool e-mail send to=$"toemail" from=$"fromemail" start-tls=yes port=587 subject="[Mikrotik Backup Export] $sysname $time" file=$"textfilename" user=$"fromemail" password=$"password"
#Send as different subjects to force GMail to treat as new message thread.
:local time [/system clock get time]
/tool e-mail send to=$"toemail" from=$"fromemail" start-tls=yes port=587 subject="[Mikrotik Backup] $sysname $time" file=$"backupfilename" user=$"fromemail" password=$"password"
 
#Allow time to send
:delay 10s
 
#delete copies
/file remove $textfilename
/file remove $backupfilename

Ganti tulisan yang diberi warna sesuai dengan detail login akun gmail Anda.

Langkah selanjutnya adalah mengatur jadwal backup kapan akan dilakukan.

Setting Jadwal Backup Mikrotik

buka system >> Scheduler >> buat scedule dengan nama backup

Backup mikrotik configuration
  1. Pada bagian start date diisi dengan tanggal saat ini.
  2. Pada bagian Start time diisi dengan jam berapa script akan dijalankan.
  3. Bagian interval isi dengan 1d 00:00:00 yang berarti script berjalan sehari sekali.
  4. Bagian policy centang semua
  5. ON Event : /system script run backup
  6. Kemudian klik ok.

Langkah selanjutnya adalah konfigurasi akun email di mikrotik.

Konfigurasi Email Backup Mikrotik

Buka Tools>> Email >> isi konfigurasi sebagai berikut :

Backup konfiguarasi mikrotik ke gmail
  1. Server : 74.125.200.108
  2. Port : 587
  3. Start TLS : Yes
  4. From : <>
  5. User : isi dengan alamat email gmail
  6. Password : isi dengan pasword gmail Anda
  7. Klik OK

Langkah selanjutnya adalah menunggu dan pastikan scheduler berjalan baik dengan melihat pada kolom Run Count

Backup Mikrotik ke email

Agar backup konfiguarsi mikrotik ke gmail berjalan lancar jangan lupa setting Allow Less Secure Apps pada akun gmail Anda.

Mikrotik configuration backup

Caranya dengan masuk/login ke akun gmail Anda kemudian akses url : https://myaccount.google.com/lesssecureapps

Hasil Backup Konfigurasi Mikrotik

Berikut contoh email masuk hasil backup konfigurasi mikrotik ke email gmail.

hasil Backup Mikrotik ke gmail

demikian info singkat cara backup konfigurasi mikrotik yang dikirimkan ke email gmail secara periodik sesuai settingan yang Anda inginkan. Semoga berguna

baca juga: Cara ngecek IMEI Ponsel (hp) BM Semua Merek di Situs Kemenperin

sumber : kb.idnix.net

Facebook :  Carasatu